System Requirements / Adobe Photoshop, Lightroom Classic, Capture One, Affinity plugin for macOS


 
Hardware requirements:

  • Apple Macintosh, starting from middle 2012
  • Metal-enabled GPU is required
  • Apple Silicon M1 optimised (two different distributives for Intel and for M1 provided with installation package)

Software compatibility:

  • MacOS Mojave 10.14.5 or later
  • Adobe Photoshop CC 2019 (version 20) or later
  • Adobe Lightroom Classic version 10.0 or later
  • Any current version of Capture One that supports external editing

Known issues:

  • Intel Iris and Intel HD Graphics GPUs may produce plugins crashes, visual glitches and artefacts. This is a system bug, the only solution is using an external GPU.
  • We do not support ‘Hackintosh’, hacked version of Adobe products and other home-brew systems, while it could worth a try.